Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    Jun 2012
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Why does Word 2010 keep switching Autocorrect lists?

    Hi all,

    I use Word 2010 on Windows 7. I alternate between US English and Canadian English, depending on the project I am working on.

    Word stores AutoCorrect entries in .acl files. My understanding is that MSO1033.acl contains AutoCorrect entries for US English, and MSO2057.acl contains AutoCorrect entries for Canadian English. I expected that when I create AutoCorrectentries, the entry would be stored in the .acl file for the language that is currently in use in the document I'm working on.

    I am working on a project where I relying heavily on AutoCorrect for technical terms. All the documents are attached to the same template, where I store styles and macros. The language is Canadian English - Normal style is set to Canadian English, all other styles are based on Normal and none of them use US English. I am obsessive about keeping styles consistent across all documents.

    But Word seems to randomly switch between MSO1033.acl and MSO2057.acl, with the annoying result that often the AutoCorrect entries I created in my last session are not available when I resume work. (I can see which file is being used by adding an entry and looking at the save date/time of the two files.) I typically work on the same document for several days, so the problem doesn't appear to be related to a particular document, or to switching between documents. I'm re-creating the entries when they aren't available so that in theory eventually both lists will contain all the entries I need, but it is frustrating and time-wasting.

    Can anyone shed any light on how Word chooses which .acl file to use? Can I have any control over it? Does Word use only one .acl file per session, or does it switch between .acl files based on settings in the current document?

    Any help would be greatly appreciated!

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    24,271
    Thanks
    5
    Thanked 1,197 Times in 1,042 Posts
    I've seen articles about turn language auto-detection off. That seems to help some people with Autocorrect issues.
    Joe

  3. #3
    New Lounger
    Join Date
    Jun 2012
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by JoeP517 View Post
    I've seen articles about turn language auto-detection off. That seems to help some people with Autocorrect issues.
    Oh, I was so hoping that this would solve my problem, but I checked and it's already turned off.

    Thanks for the suggestion, one more thing to cross off the list.

  4. #4
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,087
    Thanks
    144
    Thanked 128 Times in 123 Posts
    Language formatting is not by document, it is by character! It can be part of a Style. It can be in text copied from a different document.
    Charles Kyle Kenyon
    Madison, Wisconsin

  5. #5
    New Lounger
    Join Date
    Jun 2012
    Posts
    16
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Through experimentation, I've learned that Word chooses which acl file (AutoCorrect list) to use based on the language of the first file you work on during the current session. Then it continues to use that acl file for the remainder of the session, even if you work on documents or sections of documents that use a different language.

    The only way I have found to force it to use a different acl file is to close Word, re-open it, and immediately open a document that uses the language that corresponds to the acl file you want to use.

    It's clumsy, but it works. Hopefully this will save someone else some frustration.

  6. #6
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,929
    Thanks
    4
    Thanked 295 Times in 267 Posts
    That is interesting. It would imply that the setting might be configurable with some VBA. I can't see anything useful but will keep looking around to see if there is something that can activate an acl of your choice.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  7. #7
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,087
    Thanks
    144
    Thanked 128 Times in 123 Posts
    Quote Originally Posted by bloomhaven View Post
    Through experimentation, I've learned that Word chooses which acl file (AutoCorrect list) to use based on the language of the first file you work on during the current session. Then it continues to use that acl file for the remainder of the session, even if you work on documents or sections of documents that use a different language.
    ***
    This is not my experience. If I have more than one proofing language in a document, Word will store AutoCorrect entries in the language file for whatever the current proofing language is. Those will be available as AutoCorrect when that language is in use as a proofing language.

    This is true for checking spelling as well as AutoCorrect. If what you describe is your experience, then something else is going on. That is not normal Word behavior.
    Last edited by Charles Kenyon; 2016-12-12 at 06:31.
    Charles Kyle Kenyon
    Madison, Wisconsin

  8. #8
    2 Star Lounger Graham Mayor's Avatar
    Join Date
    Mar 2016
    Location
    Cyprus
    Posts
    108
    Thanks
    0
    Thanked 39 Times in 37 Posts
    It's not my experience either and it is easy to demonstrate. Add the autocorrect button to the QAT (Quick Access Toolbar)
    click the button and you get a dialog that shows the current autocorrect language.
    Press Left Alt+Shift (or whatever you have changed the language shortcut to) and click the button again and see the change to the dialog.

    autocorrect.png
    Graham Mayor - Word MVP
    http://www.gmayor.com

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •