Results 1 to 13 of 13
  1. #1
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Open file security warnings Windows Server 2008 R2 - nothing is working...

    Hi Guys,

    i have a very, very big problem because of i have tried all found internet's methods but this is still not working...

    I have Access Runtime 2010 on my Server which its running the code. This code is creating back-up of my database within UNC path:

    \\nt-wro4-01\dane\ihrm\dokument\worek\KADRY\DOKUMENTY _BRAKI\

    And buuum:

    nowe.png

    message box is shown as above and my macro is stopped - i have to manually open file ...

    I tried:

    1. add save zone information to attachments in registry:

    registry1.png

    2. add access trusted location in registry:

    registry2.png

    3. add sites (unc path) in security tab within internet properties :

    Bez*tytu?u3.png

    4. I was trying also this solution :

    https://www.experts-exchange.com/que...y-Warning.html

    And nothing ! How it is possible ? Is here maybe Windows Server Guru with willingness to help ?

    Thank you in advance,
    Best Wishes,
    Jacek Antek

  2. #2
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,954
    Thanks
    62
    Thanked 1,104 Times in 1,027 Posts
    Can you translate that message? My Polish isn't that good.

    If the message is that you can't write to the share then it's likely to be a permission problem. Does the user who runs Access have permission to the share?

    cheers, Paul

  3. #3
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Paul,

    it is working... thank you very much and sorry for my english...

    Warm regards,
    Jacek

  4. #4
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Okey Paul,

    sorry my joy was too soon...

    I have write to my IT department and get all unc accesses and still nothing.
    Any ideas what else can i do ?

    Maybe should change path in registry because "S:/" is not accepted ?

    Please help,
    Jacek Antek

  5. #5
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,954
    Thanks
    62
    Thanked 1,104 Times in 1,027 Posts
    You are using a UNC path so there is no drive required.
    What does the error message say? Rough translation is OK.
    What user is running Access? Is it a service account for the back end or are you running it as you? Does the Access user have permission on the share?

    cheers, Paul

  6. #6
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hi Paul,
    thank you for your help!

    My message is:
    https://i.stack.imgur.com/1fEgM.png

    I am user ljar01:

    dost?p.png

    and running access from server qvp-03. Access user - ljar01 has access to unc path - i asked my IT department for it. Additionally server qvp-03 has also full access to unc path.

    I have no idea how to tun it off. Now i am doing workaround --> using sendkeys in order to automatically press button "open" but it is not quite good...

    Best Wishes,
    Jacek Antek

  7. #7
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Anyone ?

    Jacek

  8. #8
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,954
    Thanks
    62
    Thanked 1,104 Times in 1,027 Posts
    The message is about opening files from an untrusted location.
    Is the database stored in that location or just the copy?
    At what point do you get the message? When you makes the copy? When you open the copy? Maybe you need to use a different method to create the copy.

    Have you tried this solution?
    https://www.puryear-it.com/adding-ne...usted-location

    cheers, Paul

  9. #9
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Paul,

    thank you for your help.

    In this location database is stored - back - end.

    Ok, i have only one Access license on my computer. I created autoexec macro like:

    Code:
    Function Import()
    
        Dim sFile As String
        Dim Db As dao.Database
        Dim oDB As dao.Database
        Dim oTD As TableDef
        Dim OtherDB As dao.Database
        Dim sPath As String
        Dim newFile As String
    
        DoCmd.SetWarnings False
    
    'On Error Resume Next
    
        sPath = "\\nt-wro4-01\dane\ihrm\dokument\worek\KADRY\DOKUMENTY _BRAKI\Back-End\Aplikacja_Braki_BE.accdb"
        sFile = "\\nt-wro4-01\dane\ihrm\dokument\worek\KADRY\DOKUMENTY _BRAKI\Archiwum_kopie\" & Format(Now(), "DD-MM-YYYY_HHMM") & ".accdb"
        
        Set Db = CurrentDb
        
        Application.CompactRepair sPath, sFile
        
        Set Db = Nothing
        
    'On Error GoTo 0
    
    'MsgBox "ok"
    
    Access.Quit
    
    End Function
    i moved this file to server and i am running it using Access Runtime.

    Yes i tried on my computer to add trusted locations and moved the file to the server.
    Problem is that on my server i have Access Runtime and no possibility to add trusted location from UI.

    Best Wishes,
    Jacek

  10. #10
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,954
    Thanks
    62
    Thanked 1,104 Times in 1,027 Posts
    This post has details for modifying the registry. You will have to use the key for the version of Office you are running.
    This post has a little more detail.

    cheers, Paul

  11. #11
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank you Paul,

    unfortunately this is not working:

    my registry based on Access 2010 from your link:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations]

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location0]
    "Path"="\\nt-wro4-01\\dane\\ihrm\\dokument\\worek\\KADRY\\DOKUMENTY _BRAKI\\"
    "AllowSubfolders"=dword:00000001
    "Description"="My Documents"
    "Date"="29/06/2017 17:50"

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location3]
    "Path"="\\nt-wro4-01\\dane\\ihrm\\dokument\\worek\\KADRY\\DOKUMENTY _BRAKI"
    "AllowSubfolders"=dword:00000001
    "Description"="My Documents"
    "Date"="29/06/2017 17:50"

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location1]
    "Path"="C:\\Users\\ljar01\\Desktop\\"
    "AllowSubfolders"=dword:00000001
    "Description"="My Files"
    "Date"="29/06/2017 17:50"


    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location2]
    "Path"="C:\\Program Files\\Microsoft Office\\Office14\\ACCWIZ\\"
    "Description"="Access default location: Wizard Databases"
    Furthermor i tried to add also allownetworklocations but this is not working too...

    Best Wishes,
    Jacek

  12. #12
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    8,954
    Thanks
    62
    Thanked 1,104 Times in 1,027 Posts
    The path doesn't seem to be correct - you need to escape a backslash with a backslash, so it should look like this.
    "Path"="\\\\nt-wro4-01\\dane\\ihrm\\dokument\\worek\\KADRY\\DOKUMENTY _BRAKI\\"

    cheers, Paul

  13. #13
    New Lounger
    Join Date
    Aug 2017
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Paul,

    I
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations]

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location0]
    "Path"="\\\\nt-wro4-01\\dane\\ihrm\\dokument\\worek\\KADRY\\DOKUMENTY _BRAKI\\"
    "AllowSubfolders"=dword:00000001
    "AllowNetworkLocations"=dword:00000001
    "Description"="My Documents"
    "Date"="29/06/2017 17:50"

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location3]
    "Path"="\\nt-wro4-01\\dane\\ihrm\\dokument\\worek\\KADRY\\DOKUMENTY _BRAKI"
    "AllowSubfolders"=dword:00000001
    "Description"="My Documents"
    "Date"="29/06/2017 17:50"

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location1]
    "Path"="C:\\Users\\ljar01\\Desktop\\"
    "AllowSubfolders"=dword:00000001
    "Description"="My Files"
    "Date"="29/06/2017 17:50"


    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\A ccess\Security\Trusted Locations\Location2]
    "Path"="C:\\Program Files\\Microsoft Office\\Office14\\ACCWIZ\\"
    "Description"="Access default location: Wizard Databases"
    my code still is not working.

    I think that i will write on microsoft forum about that...

    Best Wishes,
    Jacek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •