Results 1 to 7 of 7
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Posts
    88
    Thanks
    6
    Thanked 0 Times in 0 Posts

    Chrome Not Responding

    If I had hair to tear out it would be gone. Can't get any help on the chrome forums.

    I have three Win 10 64bit laptops all running the latest versions of Win 10. After the latest version of Win 10 was installed several weeks ago I started having issues where chrome would just become unresponsive. Couldn't type in the search bar and eventually you would get a not responding message. Sometimes it would fix itself after several minutes but often only a restart would solve the problem. Initially, this was happening on only one of the computers then it began on another. It has reached the point in the last couple of days where it stops working multiple times a day.

    No problem with IE or Edge. However, I'm a long time user of chrome and it syncs across multiple devices for us so I would prefer not to abandon it. I haven't added a new extension in a very long time. I have uninstalled and re-installed it twice in the last couple of weeks.

    Any suggestions?

  2. #2
    Star Lounger
    Join Date
    Dec 2009
    Posts
    88
    Thanks
    6
    Thanked 0 Times in 0 Posts
    Thought I would update this. I have uninstalled this yet again and used Geek uninstaller to do it. Removed every trace it could find. Installed again which now required signing to the google account twice. Now it essentially doesn't work. Freezes pretty much as soon as it opens.

  3. #3
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    9,268
    Thanks
    68
    Thanked 1,148 Times in 1,071 Posts
    Fire up Chrome in incognito mode (Ctrl Shift N) to disable all extensions. Does it still freeze?

    cheers, Paul

  4. #4
    Star Lounger
    Join Date
    Dec 2009
    Posts
    88
    Thanks
    6
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Paul T View Post
    Fire up Chrome in incognito mode (Ctrl Shift N) to disable all extensions. Does it still freeze?

    cheers, Paul
    Thanks, Paul. I finally got it to open and work for the moment. I went into extensions and have turned off all except those that I really want to keep using. They include, Roboform, Ublock, HTTPS everywhere, Kindle and Grammarly. I'm going to see if that works and, if not, will try your suggestion. Do you happen to know if these extensions automatically update themselves?

    Jim

  5. #5
    WS Lounge VIP
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    9,268
    Thanks
    68
    Thanked 1,148 Times in 1,071 Posts
    Nope, don't know.

    cheers, Paul

  6. #6
    Star Lounger
    Join Date
    Dec 2009
    Posts
    88
    Thanks
    6
    Thanked 0 Times in 0 Posts
    Problems persists. Any other suggestions? I didn't try starting with all extensisons disabled since they are a must for me and will have to find another browser if this won't work. Moreover, another laptop running the same setup doesn't have this issue.

  7. #7
    Administrator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    7,001
    Thanks
    123
    Thanked 827 Times in 742 Posts
    I would still try starting with all extensions disabled to determine if one of them is the cause. If it is and you can't live without it, you can then move on to another browser.

    Jerry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •