Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts

    Outlook 2010 slow to move emails

    This issue has been frustrating me for quite a while. I have tried absolutely everything I know and read (the list is very long), but so far nothing has resolved it.

    I file the emails I want to keep in separate folders. Whenever I drag-and-drop an email to a folder, Outlook pauses for 3-5 seconds depending on the number of emails in the target folder (at most a few hundred) before the email moves to that folder.

    My troubleshooting suggests that Outlook is indexing the target folder, during which time it appears to 'freeze', then once it has finished indexing, the email moves.

    The following is what I have observed:

    1. If I drag-and-drop an email to a folder containing a number of emails, Outlook 'freezes' for 3-5 seconds, then the email moves. If I then move another email to that same folder, that email moves instantly.

    2. If I drag-and-drop an email to an empty folder, it moves instantly.

    3. If I drag-and-drop an email to a folder that has only one or two emails in it, the move is almost instant.

    I would be very grateful for some advice on how to resolve this annoying issue.

    Regards
    useful

  2. #2
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    5,163
    Thanks
    189
    Thanked 731 Times in 644 Posts
    Last edited by BruceR; 2018-01-07 at 08:40.

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    24,507
    Thanks
    5
    Thanked 1,233 Times in 1,073 Posts
    What leads you to think that indexing is the issue? More likely it is just Outlook enumerating the emails already in the folder. Outlook must do that to determine if the email already exists so that it can take appropriate action.
    Joe

  4. #4
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Hi BruceR

    Thanks for your response.

    I have done all of those things and followed the suggestions in the troubleshooting link you have referred me to, but all to no avail.

    Regards
    useful

  5. #5
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Thanks for your response JoeP517.

    I was just guessing about Outlook indexing. I really have no idea what Outlook is doing, it just 'freezes'.

    Enumerating emails already in the folder would also explain the 'freeze', but given that Outlook does not 'take appropriate action' about an email that already exists in the folder (I have tested it), is there any way that this can be turned off? It is just annoying and does not achieve anything.

    Regards
    useful

  6. #6
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    5,163
    Thanks
    189
    Thanked 731 Times in 644 Posts
    What's the size of the data file now?

    Have you tried Reset View to default on a slow folder?

    Comprehensive Guide on Addressing Slow / Sluggish Outlook Performance to Microsoft Exchange

    Same issue for five years, but the folders haven't grown beyond a few hundred messages each? MS Outlook 2010 Drag-and-Drop is slow

  7. #7
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Thanks for your response BruceR.

    > Have you tried Reset View to default on a slow folder?

    Yes, it makes no difference.

    > Comprehensive Guide on Addressing Slow / Sluggish Outlook Performance to Microsoft Exchange

    I am not running Microsoft Exchange.

    > Same issue for five years ...

    You are quite right, I have had this issue for five years and not a lot has changed.

    I am fairly sure that JoeP517 is right and Outlook is enumerating the target folder prior to moving an email, but I'm not sure why. If I could stop Outlook from doing this, my issue would be resolved.

    Regards
    useful

  8. #8
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Surrey, UK
    Posts
    200
    Thanks
    8
    Thanked 49 Times in 44 Posts
    Whilst googling, I found your first plea for help on this forum dates back to 2012. You mention indexing as the likely cause, so I tried Outlook's (2010) help and it could find no references to 'index', which is pretty hopeless, since if you go to File>Options>Search there is a reference to Windows Search and Index:
    Outlook options snip.PNG
    I am using W10, but I believe this integration between Outlook and Windows Search (which I was unaware of) was also present in W7 (which you may still be using, as in 2012). When you (or rather I) select 'Options', this is what I see:
    Outlook index snip.PNG

    Now this is not very informative, but what sent me looking for this was a link I found that showed that Windows search could be configured to look inside Outlook, so I clicked 'Modify', and got this:
    outlook index sources.PNG
    I added Outlook to the selected locations (it was not selected initially), but as my Outlook .pst file is tiny, it had no effect - but there is a slim chance that this is contributing to your problem. Have a look and see what Windows search is monitoring on your PC.

    HTH, Martin

    PS You haven't told us how big your .pst is - it was 4.5GB by Feb 2013
    Last edited by mngerhold; 2018-01-08 at 12:19.

  9. #9
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Thanks for your response mngerhold.

    One of the long list of things I tried is the Search you found and in my case, only Outlook is ticked, but it makes no difference.

    Also, the size of the .pst file is not the cause of my issue (I tried archiving until it was really tiny and it made no difference).

    Although my initial suspicion was indexing, because I could not imagine what else Outlook would be doing in the background and 'freezing', I have now changed my mind and believe JoeP517 who suggested that Outlook was enumerating the target folder. This is a pointless exercise, but I cannot find any way of turning it off, which would, of course, solve my issue.

    Regards
    useful

  10. #10
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    4,066
    Thanks
    545
    Thanked 476 Times in 445 Posts
    I assume that your email is set up as POP3, from the things you have said. The following applies if you are set up as POP3.

    Sometimes a PST file can get corrupted, so it is a good idea to start fresh with a new one. Create a new PST file, then move all of your email from the old one into the new one. Then make the new one your default PST file for Outlook.

    I prefer fixing a PST file this way, rather than doing a repair on an existing PST file. This way, you KNOW that you will get a clean, error-free PST file.

  11. #11
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Thanks for the suggestion mrjimphelps.

    I have tried this as part of a long list, which is as follows:

    1.Running Outlook in safe mode
    2.Clean boot of PC
    3.No active application add-ins in Outlook
    4.Disabled and even uninstalled anti-virus software
    5.Archived and compacted .pst file down to 200MB (although I have not observed this behaviour in a .pst of 10GB on another PC)
    6.New Outlook profile
    7.New Outlook data file
    8.Repair of Office 2010 (in Control Panel)
    9.Running SCANPST several times
    10.Enabled the Group Policy (and forced an update) to prevent indexing in Outlook
    11.Office 2010 SP1 is installed with all latest patches (last being 14 Feb 2013)

    As I mentioned in an earlier post, my initial suspicion was indexing, because I could not imagine what else Outlook would be doing in the background during which it 'freezes', but I now believe JoeP517 who suggested that Outlook was enumerating the target folder, which is consistent with my troubleshooting. This is a pointless exercise, but I have not been able to turn it off.

    Regards
    useful

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    24,507
    Thanks
    5
    Thanked 1,233 Times in 1,073 Posts
    I don't think you can disable the enumeration of folder contents. That is a basic function usually required to do anything in a folder.
    Joe

  13. #13
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Surrey, UK
    Posts
    200
    Thanks
    8
    Thanked 49 Times in 44 Posts
    I am intrigued, but hampered by not being able to replicate your issue - many users have problems with sluggish performance, but it seems you have checked everything. But have you tried running the Support and Recovery Assistant for Office 365? https://diagnostics.outlook.com/#/

    I know you are not on Office 365, but I found the link to that here, and it says the tool works for other versions of Outlook. If I had a problem I'd run it myself!

    Failing that, have you looked in Windows Event Viewer - it may be there is a problem being logged there at the times you see the delays?

    I did also wonder if there was anything special about the emails you are moving - do they perhaps contain embedded links to external content (many commercial ones do)? I don't know why they would cause a problem, but perhaps Outlook is trying to read them while it copies (very much a long-shot).

  14. #14
    3 Star Lounger
    Join Date
    May 2002
    Location
    Melbourne, Australia
    Posts
    279
    Thanks
    32
    Thanked 0 Times in 0 Posts
    Thanks for your response mngerhold, I'm grateful for your continued interest.

    Your link lead me to the Microsoft Support article which explains that my problem may be caused by having too many folders. Apparently Outlook 2010 is limited to 500 folders (which I did not realise). The number of items per folder does not apply to me.

    As a result of being a careful filer, I had 1,047 folders in my PST file and also discovered that Archive does not remove empty folders, which is why archiving by itself did not help me earlier.

    As a result, I archived my PST file, then went through and manually removed all of the empty folders, so that I reduced the number of folders in my PST file down to 453.

    I then compacted my PST file and ran SCANPST a few times until there were no further errors found.

    Keen to test my problem at last, I was disappointed to find that Outlook still 'froze' after the first drag-and-drop, but was immediate on subsequent ones.

    Then I thought I would download and try the Diagnostic Tool, albeit it was intended for Office 365, as the article pointed out that it would not just work for Office 365. Sadly, this is not quite true, as you need valid credentials for Office 365, which of course I do not have.

    I'm glad that I now have a 'leaner' PST file, but I am no closer to solving my problem!

    Regards
    useful

  15. #15
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Surrey, UK
    Posts
    200
    Thanks
    8
    Thanked 49 Times in 44 Posts
    I decided to do some more tests on Office 2010 running under W10, and found that I can replicate the problem - as you noted, it only occurs when copying (but maybe only moving) to folders with a 'large' number of emails (where large might mean 50 or more). It only occurs on the first instance of copying to that folder, after which subsequent copies are snappy (until Outlook is closed and opened again). This is on a pst file with no more than 1000 items and ~100MB in size, with an 11-year old Athlon 64-x2-3800 cpu.

    I spent some time trying to fathom out what Outlook was doing during the (in my case ~3sec) delay, by running Sysinternals Procmon.exe, which monitors registry, file system and network activity. This is hard work, as thousand of events can occurr every second, and one has to filter them out until only 'relevant' ones are left. Then one tries to match the delay to some part of the log of events.

    I found some registry references to 'Trusted documents' seemed to coincide with the delay, but clearing whatever I could in options had no effect. I also found Outlook was creating a new thread occasionally (I have no further idea what that implied) that coincided. I wasted some time finding out how to turn off ctfmon.exe (associated with tablet and hand-writing recognition), which also had no effect. I did discover my installation of Outlook was running some addons I had no use for, so that speeded up the many restarts!

    I am afraid I have no idea what is causing the delay, beyond what you have already surmised, but can confirm that outlook is performing a lot of search-related registry activity. It does seem that it takes it a while to update the recipient folder index (or whatever). However, as this only occurs once per folder and session, it does not seem to warrant any further investigation - sorry I couldn't help.

    atb, Martin

    PS Since I have access to a somewhat newer and slightly faster PC, I may have a further look (give a dog a bone....)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •