Results 1 to 2 of 2
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Thanked 0 Times in 0 Posts

    Print Properties for Macro (97)

    I am manually trying to create a macro and then edit it. I want to print a document where the first page prints on letterhead. In the macro I select print, single page, go to properties and select paper type "letterhead" and turn off duplexing. I select print again to print the rest of the document (I use some code to have it start on the second page) go to properties and select paper type (not letterhead), and turn on duplexing. When I play the macro back, the macro does not change the properties. The properties stay the same as what I selected manually the second time. If I use the macro, I have to create 2 macros and change the settings manually before running each macro. I am not sure what the coding would be to capture these property settings. Anyone know what I am trying to do?

  2. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Silicon Valley, USA
    Thanked 94 Times in 90 Posts

    Re: Print Properties for Macro (97)

    It sounds as though the changes are being made in the printer properties dialog, a Windows-level dialog that Word cannot record when recording a macro.

    If there are not equivalent settings in Word itself, for example, in the Page Setup or Print Options dialogs, then it gets more difficult. Crusty old KnowledgeBase article Q194306 demonstrates how to insert a PRINT field or use SendKeys to turn on duplex printing. The latter is not a highly reliable method, while the former requires some careful placement and possibly research on manufacturer printer codes. In <!post=Post #84646,84646>Post #84646<!/post>, Kevin gives some detail from his codes research for HP printers.

    If the above doesn't work and you are ready to take on the Windows API, <A target="_blank" HREF="">Microsoft

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts