If any of you MozillaFirebird fans should also happen to be WebFerretPro fans......here's how you can make Firebird your Client Browser.

Note: Read the WHOLE POST before you do anything !!!


The following is a copy of a response from FerretSoft Support. BTW, IMHO, they were very prompt and helpful.

Subject: WebFerret Feedback

We do not officially support Mozilla Firebird, yet.

There is a way to do what you want, but it will involve at least one registry change, and first you will have to be certain that WebFerret believes Mozilla is NOT installed.

Step 1: In WebFerretPRO, go to View->Options and then click on the Client Tab. Make sure Mozilla is NOT selectable in the drop-down. You may have to move or delete or uninstall your older Mozilla install (and then restart WebFerret) in order to do this.

Step 2: Launch regedit and open Key:

HKEY_CURRENT_USERSoftwareFerretSoftNetFerretCurren tVersionBrowser

Change the value of MozillaSearchFilename from "mozilla.exe" to "mozilla*.exe".
(If you are using Firebird, I'll assume you know how to modify the registry and realize Firebird is still beta software).

Step 3: In WebFerretPRO, go to View->Options and then click on the Client Tab, again. This time, click the Add button. Then choose Mozilla, and give it the location of your MozillaFirebird.exe). Click Close, then make sure Mozilla is chosen in the Web browser drop-down on the Client Tab, click OK, and try some searches.

Have fun! If this works for you, you may have to repeat these steps whenever WebFerretPRO patches itself (i.e. when ever the Patch level increases as shown on Help->About WebFerretPRO)


The following is my reply back to them, outlining what I had to do to make it work.

I found the key as described, except only to "CurrentVersion", in "HKEY_Local_Machine". I added the rest of the key info as suggested.

When trying to add the location info in WebFerretPro, WFP would NOT recognize "MozillaFirebird.exe". I guess the "*" trick didn't work.......however, I copied "MozillaFirebird.exe" to the Desktop, renamed the copy "Mozilla.exe" and moved it back into the same folder as "MozillaFirebird.exe".

This time...it worked. A bit convoluted, and the registry edit may not have been required, but it worked !

Have a Great day!!!