I'm cleaning out a PC that had a bunch of adware (using AdAware, SpyBot and TrendMicro) and I'm down to the following stubborn problem. For WebHancer and Zango I've deleted the folders and files but there are some registry entries that I CANNOT get deleted. For example, I have the following object (1 of 9 that are all similar):


When I click on it initially in regedit, I get "Error while opening key". The second time, it is hilited so I attempt to delete it and get "Cannot delete xxx: Error while deleting key". I expand it and see that it has a subkey, CLSID that also gives the "Cannot open CLSID: Error while opening key" message initially. Similarly, I also cannot delete it. So, to make a long story longer, I tried to check the permissions and got "You do not have permission to view the current permission settings for CLSID, but you can make permission changes". OK. I add myself (an admin account) and select "full" but when I click OK or Apply, I get "Unable to save permission on CLSID. Access is denied." This happens no matter what user I try. I am also unable delete, rename, or to take ownership of any of these objects or see the effective permissions.

I downloaded RegSeeker and it finds the objects but is unable to delete them as well (even though there are no warnings as with SpyBot, AdAware or Trend Micro - the keys are always there after a delete operation).

I'd appreciate any advice or tools that anyone has.


Michael C.

Update: I found this advice: "Right click security/permissions. Click add - advanced - find now - everyone then ok and give full control, then click advanced -go to the owner tab click "admin or user in white box "click replace owner on..... box click ok - you will get an error message " access denied" click ok. At permissions box click apply and ok it should work."

While that didn't work for all of the entries, some combination of clicking "Apply" and "OK" in various places to the objects and/or subkeys eventually allowed me to delete all of them eventually. I'm not sure I could repeat the steps. Not pretty and certainly not logical given the number of error messages and warnings but it worked.