Results 1 to 2 of 2
  1. #1
    3 Star Lounger
    Join Date
    Apr 2001
    Warrington, Cheshire
    Thanked 0 Times in 0 Posts

    Record is deleted (97 sr2)

    The search results I got for "record is deleted" dated way back to 2002 - but unfortunately haven't resolved it for me:

    I have a table which is appended to each evening in the wee small hours using an append query.
    Came in this morning and is throwing an error with "Record is deleted"

    The setup is:
    tbl_Perms - is the final data table to be appended to
    dbo_Invoices - is the networked database table from which the perms information is derived
    through a query I link the tbl_Perms to dbo_invoices and where the invoice number in tbl_Perms is null then I append the missing data

    So far it has been working fine and I have not made any changes to the db to create this error.

    On checking the query I can see no problems with users accessing the tables in the background.
    I have compacted and repaired the database successfully.
    I have confirmed that the updated fields are all alike in their properties.
    When I run the append query just to see the resulting rows (only two rows today) I can see the new rows ready for appending.
    When I try and run the query in it's append mode I get the "Record is deleted" error.

    I copied the tbl_Perms as a new table tbl_PermsTest and used this as the target table for the appending - the append query worked correctly when doing this.

    Any suggestions?

  2. #2
    Plutonium Lounger
    Join Date
    Mar 2002
    Thanked 31 Times in 31 Posts

    Re: Record is deleted (97 sr2)

    It's hard to know what happened, but my guess is that tbl_Perms has become slightly corrupt, for example an incorrect index. Copying to a new table probably forced Access to create the index anew. So I'd use the new table instead of the old one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts