Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts

    IP address conflict error

    Hi all. My husband and I have a shared internet connection. My W7 PC is connected to our Netgear router by cable and his W7 laptop is connected wirelessly to the same router. We've had this set up for a few years now. This morning a box popped up on his screen saying that there was an IP address conflict and that two computers on the network had the same IP address. This doesn't seem to have caused any problems as we can both still access the internet.

    Why has this suddenly occurred? Do I need to do anything about it given that both of us can still use our machines? (I'd hate to "fix" it and find that one of us cannot use the internet!)

  2. #2
    WS Lounge VIP Coochin's Avatar
    Join Date
    Jun 2014
    Location
    Queensland, Australia
    Posts
    2,157
    Thanks
    31
    Thanked 307 Times in 267 Posts
    Do you have a network-connected printer (wired or wireless)?

    If you do then try leaving the printer powered-off until the computers are up-and-running and connected to the network without errors. Then turn the printer on and there should not be any "IP conflict" error.
    Computer Consultant/Technician since 1998 (first PC was Atari 1040STE in 1988).
    Most common computing error is EBKAC: Error Between Keyboard And Chairback
    AMD FX8120 (8-core @ 3.1GHz) CPU, Gigabyte GA-990FXA-D3 motherboard, 8GB (2x4GB) DDR3 1866MHz RAM, ATI-AMD Radeon HD6770 PCI-E VGA, 480GB Kingston SSD, 2TB Seagate SATA3.0 HDD, ASUS DVD/RW.

  3. The Following User Says Thank You to Coochin For This Useful Post:

    sylviesinc (2015-06-05)

  4. #3
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    The printer is connected to my PC only, wirelessly. I didn't actually set up a proper "network" as my husband only surfs the web, uses Google, reads the news etc and doesn't need to share anything with me.

  5. #4
    jwoods
    Guest
    It sounds like the IP address for the printer (or some other device) may have been assigned a "static" IP address in the same range as the DHCP "private" IP addresses used for your other devices.

    Any static IP address should be assigned outside of that range to avoid IP address collisions.

    So for example if the DHCP range is 192.168.1.25 to 192.168.1.199, you would assign the static IP to 192.168.1.24, or 192.168.1.200, and so on.

  6. The Following User Says Thank You to jwoods For This Useful Post:

    sylviesinc (2015-06-05)

  7. #5
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    Thanks for the explanation, which I confess that I don't understand, but this printer has been wirelessly connected to my PC for a couple of years now without any problems, and my husband's laptop has never used it so I don't understand why his laptop should suddenly have this conflict!

  8. #6
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    It's unusual to be able to maintain a connection when you get an IP conflict as one usually cancels the other out for both devices.

    If the printer isn't switched on when hubby gets this error then it won't be the printer.

    Other culprits can be iPhones which can hang onto the same IP address so when the router's DHCP assigns IP addresses to devices as they are switched on, DHCP could reissue the iPhone's original IP address to another device which would result in the message your hubby is getting.

    A simple solution is to just switch the router off for about 30 secs if it causes problems, but if you have any iPhones or the like that uses the home WiFi then check to see if they have a connection when the error message appears.

  9. The Following User Says Thank You to Sudo15 For This Useful Post:

    sylviesinc (2015-06-05)

  10. #7
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    Thanks again. We don't have any other devices as we're a couple of old fogies and the computer is my only guilty pleasure. As we've had no problems connecting, either of us, I'll just put it down to gremlins and, should it recur tomorrow, I'll try rebooting the router, as suggested.

  11. #8
    Super Moderator
    Join Date
    Aug 2012
    Location
    Durham UK
    Posts
    6,645
    Thanks
    147
    Thanked 884 Times in 845 Posts
    Routers can get glitchy sometimes but a reboot usually clears it.

    Try not to reboot it at peak times as you could end up with a lower sync speed.
    Last edited by Sudo15; 2015-06-05 at 18:12.

  12. The Following User Says Thank You to Sudo15 For This Useful Post:

    sylviesinc (2015-06-06)

  13. #9
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    It's ok this morning...so far but I will remember. Thank you

  14. #10
    3 Star Lounger
    Join Date
    Sep 2010
    Location
    Yarra Glen, Victoria, Australia
    Posts
    213
    Thanks
    0
    Thanked 39 Times in 25 Posts
    If you know the MAC (Media Access Control) address of each device, you should be able to set up your router so that each device always gets a specific IP address. In the LAN/DHCP settings in the router, you should be able to set it up so that MAC address A will always get IP address X, MAC address B will always get IP address Y, and so on. In your case it would look something like this:

    Enable DHCP Server
    Start IP Address: 192.168.1.100 (for example)
    End IP Address: 192.168.1.102

    Static IP Lease List:
    MAC Address IP Address
    (Your PC) 192.168.1.100
    (Hubby's PC) 192.168.1.101
    (Printer) 192.168.1.102

    The router would then always give each device the IP address specified.

    To find the MAC addresses, open a command prompt and issue the following command:

    getmac /v /fo list

    Each device, including the printer, should be connected to the network at the time. The result will show a "Physical Address" for each device; this is the same as the MAC address.

  15. The Following User Says Thank You to Bundaburra For This Useful Post:

    sylviesinc (2015-06-11)

  16. #11
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    Thanks for this. The problem hasn't recurred so I won't actually do anything as I don't believe in fixing stuff unless it's broken but, this is information I will use if it happens again.

  17. #12
    New Lounger
    Join Date
    Jun 2011
    Posts
    21
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Here's a possibility. Does your wireless router have a non-default password associated with it or can just anyone connect to it? If it is not secured with a password then perhaps someone in your area is using your router with a static address (one that doesn't change) and this is what is sometimes causing your conflict (your address changes from time to time and sometimes that is the same as the mystery person's address).

    If you do use a password then that's less likely unless the password is easy to guess or is the default password such that anyone could look up the default password.

    HTH (Hope this helps).

  18. The Following User Says Thank You to LHuisingh For This Useful Post:

    sylviesinc (2015-06-11)

  19. #13
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    Well, it isn't password protected mainly because we live in an isolated retirement community and my immediate neighbours don't have computers. That is something I can address should it happen again. Thank you.

  20. #14
    Star Lounger
    Join Date
    Dec 2009
    Location
    warren, ohio
    Posts
    66
    Thanks
    1
    Thanked 13 Times in 6 Posts
    quick method if it happens again. Power off both computers. power off printer. power off router. In that order. Then, turn router on, wait a minute or two for it to connect to internet, then turn on computers and printer. That should allow the DHCP server inside the router to give every device a new address that will not conflict with anyone.
    But you should put a password on your wifi. Even though your neighbors do not have computers, if they have visitors with smartphones, the first thing those visitors will do is notice your free wifi and log on.

  21. The Following User Says Thank You to dalejanus For This Useful Post:

    sylviesinc (2015-06-12)

  22. #15
    2 Star Lounger
    Join Date
    Dec 2009
    Location
    Suffolk, UK
    Posts
    122
    Thanks
    54
    Thanked 2 Times in 2 Posts
    That's great advice thanks, and I will put protection on my connection!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •